Vim scrolling with touchpad too sensitive - macos

I'm using vim (7.4.898) on Mac OS Sierra and iTerm2 (latest version). I have set mouse=a enabled in my .vimrc. Since the upgrade to Mac OS Sierra, the scrolling with the touchpad in vim is way too sensitive. Scrolling otherwise works fine. Is there a way to adjust the sensitivity somewhere (either in MacOS, iTerm2 or vim)?

I am now using a new MackBook Pro. The scrolling issue completely disappeared for me.

Related

Disable booting sound in MacOs 10.14.3 Mojave + Win10 bootcamp

How can i disable booting mac sound via using bootcamp?
I tried to use sudo nvram SystemAudioVolume=%01, but it worked only once. After the second reboot sound appeared again. I don't have a special checkbox which can disable the sound in "sound settings" in this version of MacOS. How can i setup the system to block this sound? Either MacOS or Windows10 (via bootcamp) boot?
I'm running Mojave 12.6.1 and I can disable the startup sound in sound settings:
https://i.stack.imgur.com/pP2nw.png
There might be a similar option for you.

In MacOS Ventura file system has changed, Apple Menu shut down, restart are not referred from StandardMenus.nib. What is the new way that is referred?

Earlier MacOS versions taskbar menu were referred from StandardMenus.nib/object.xib. The current MacOS Ventura doesn't have anything mentioned about Shut Down, Restart, Force Quit mentioned under object.xib. Also noted a new file Menus.loctable which has the text referred. How do we see the menu lists in the new MacOS Ventura system?
This can't be done because Apple has changed the file system in the ventura though you can change edit the strings in menu.loctable using plutil.

Netbeans: Customize Toolbars in Mac Sierra 10.12.4 Not Working

I am trying to customize my toolbar in Netbeans on a MacBook Pro running Sierra 10.12.4.
I can 'add a custom toolbar' and name it, but when I try to drag and drop the desired icons into the bar, they don't get added, don't even register as hovering behavior when attempting it.
Works fine on my PC but not on my Mac.
Is this a bug or am I missing a step, or it just doesn't work on Mac?

disable XQuartz and revert to mavericks's default x server

I have installed XQuartz 2.7.5 on Mavericks. After that videos I play with mplayer seems to load on a separate window, all white stuck with only the audio playing. I have disabled Xquartz by disabling /Library/LaunchAgents/org.macosforge.xquartz.startx.plist and /Library/LaunchDaemons/org.macosforge.xquartz.privileged_startx.plist with launchctl.
Iwould like to know how to display the videos as it was playing before. I installed mplayer via brew. Is there a way to direct $DISPLAY to the default x server? Please help.
Thanks
Don't disable /Library/LaunchDaemons/org.macosforge.xquartz.privileged_startx.plist. That will prevent XQuartz.app from launching.
Disabling /Library/LaunchAgents/org.macosforge.xquartz.startx.plist (and relogging) will result in the DISPLAY environment variable not being set and thus automatic launching of XQuartz.app when you run X11 applications, but you can still launch XQuartz.app directly.
There is no default X server. X11 was removed from OS X in Mountain Lion. X11.app in earlier versions of OS X was just XQuartz.app with different name.

Mac OS X vim colors mangled

Here's my setup
Mac OS X 10.6
VIM (default version that comes with OSX 10.6)
rails.vim (installed in .vim/autoload)
ir_black.vim (installed in .vim/colors)
i have "colorscheme ir_black" and "syn on" in ~/.vimrc
Now when I go into terminal and edit a ruby file with vim my colors are messed up. There are only a few colors showing up and some text is even blinking. I'm wondering if there's a conflict between rails.vim syntax highlighting and the ir_black color scheme? Can anyone help me fix this? I would like to use the ir_black color scheme.
The Mac OSX Terminal.app in Snow Leopard does not support 256 colors, which is required for the ir_black theme (this is the theme I use).
Download and try something like iTerm.app (http://iterm.sourceforge.net/), and you shouldn't have a problem with colors.
Or you could use MacVim (http://code.google.com/p/macvim/)
Edit: As of OSX 10.7 Lion, the built in Terminal.app now supports 256 colors. See the comment below by Chris Page for how to achieve this.
I've been using a nearly identical setup, except for vim, which I grab from Macports. A few years ago I found ir_black and loved it. I now use it for all vim sessions, Terminal.app, and TextMate. Getting it to work with Leopard, and then Snow Leopard was a tad hokey. But things have improved. Follow the instructions here, Making Terminal.app look great in Snow Leopard.
As mentioned by others, ir_black requires 256 colors, which is not supported by Terminal on 10.6.x and earlier.
As of Mac OS X Lion 10.7, Terminal now supports 256 colors and the default $TERM value is xterm-256colors. ir_black should work fine for you if you upgrade to Lion.
on testing which colors can be displayed in your terminal of choice:
i just found this perl script on vim.org which dumps a list of 256 colors your terminal could possibly display...
http://www.vim.org/scripts/script.php?script_id=1349
I have been using iTerm and was shocked to find out Terminal.app doesn't support 256 colors! I recommend Bryan's answer.
However, if you ever get in a bind like this, you can change $TERM to vt100 and vim won't try to use colors. In bash (the default MacOSX shell) you set this with:
export TERM='vt100'
I use ir_black in Terminal.app but in 16 color mode, and it looks great. If you really prefer 256 color, I recommend iTerm2. The settings allow you to have the terminal report itself as "xterm-256" which is what's needed to use 256 colors in Vim.
Check this website for the procedure:
http://kevin.colyar.net/2011/01/pretty-vim-color-schemes-in-iterm2
There is a ir_black-based Vim theme called tir_black which is better suited for 256 colors:
http://www.vim.org/scripts/script.php?script_id=2777
Looks awesome!
iTerm2 also has loads of nifty features.
I hope this helps.
I had the same issue with iTerm and solved it by going to Settings > Profile > Terminal > Report Terminal Type and setting it to xterm-256color.

Resources