I have tried to disable SIP from OS X El Capitan following the procedure
Enter Recovery Mode
Open terminal
csrutil disable
and it works fine, if I type csrutil status it is disabled.
Then I restart my computer, but in my terminal the csrutil status returns this
System Integrity Protection status: enabled (Custom Configuration).
Configuration:
Apple Internal: disabled
Kext Signing: disabled
Filesystem Protections: disabled
Debugging Restrictions: disabled
DTrace Restrictions: disabled
NVRAM Protections: disabled
This is an unsupported configuration, likely to break in the future and leave your machine in an unknown state.
Why is it still enabled? I need to disable it because otherwise the system won't recognize my Vodafone key in Vodafone Mobile Broadband.
Apparently this is a known bug. See https://openradar.appspot.com/22361698 ; that is listed as a duplicate of another bug but that other bug doesn't appear to be publicly accessible.
Related
How can i disable booting mac sound via using bootcamp?
I tried to use sudo nvram SystemAudioVolume=%01, but it worked only once. After the second reboot sound appeared again. I don't have a special checkbox which can disable the sound in "sound settings" in this version of MacOS. How can i setup the system to block this sound? Either MacOS or Windows10 (via bootcamp) boot?
I'm running Mojave 12.6.1 and I can disable the startup sound in sound settings:
https://i.stack.imgur.com/pP2nw.png
There might be a similar option for you.
In Xcode 11.1, I have disabled SIP and set System Preferences as the debug executable. When I run my build, System Preferences loads, but when I open my prefPane, no breakpoints are ever hit.
This worked fine in 10.11 to 10.14.
With SIP enabled, I get a "can't attach to System Preferences" error as expected. But I am at a loss as to why the break points are never hit as they have been with earlier macOS versions.
I have a background process that is used by the prefPane and I am able to debug that just fine, but trying to debug the prefPane while it is running in System Preferences doesn't work anymore.
Has anyone got a solution?
Could this be because the prefPane is actually run in "legacyLoader" which is sub-launched by System Preferences?
I needed to specify "legacyLoader" as the executable and not launch it automatically, but instead wait for it to be launched.
I still don't know how to do this without disabling SIP since there is no way to tell System Preferences to open an alternate (self-signed) copy of legacyLoader instead of the default system one.
When I disabled SIP via recovery mode, the kext could be loaded by kextload, anyway, when system restart, kext will not be loaded by kext manager like it supposed to be in Mojave and lower.
If I enabled SIP and load the kext (the kext is full functional with 10.14 -), it will show following message
Kext rejected due to system policy: <OSKext 0x7ff02df0b450 [0x7fff89d4aba0]> { URL = "file:///Library/StagedExtensions/Library/Extensions/...
BTW, In Catalina, how user to allow a kext ? I know in 10.13, it will show on the General of Security & Privacy, in 10.14, I was using Kextdrop, anyway, kextdrop won't work with Catalina.
Found out I just need sign the kext and notarize the kext in order to get system to load it
So my mac kernal_task keep using 600%++ of my CPU usage when my Mac is plugged in, and thus i decided to delete the IOPlatformPluginFamily.kext by doing these steps:
Enter Recovery Mode
Open Terminal
Disable SIP: csrutil disable
Enter Single User Mode
Delete the kext file
But will the kext file come back if i enable SIP again?
I'm currently using High Sierra but i have been doing this since Sierra
And i followed this guide https://www.davidschlachter.com/misc/kernel_task
This is the log in console.
2016-10-19 4:35:30.377 PM com.apple.CoreSimulator.CoreSimulatorService[761]: Error saving /Users/myusername/Library/Developer/CoreSimulator/Devices/14ABD200-69D3-441D-8FAA-731F5F00F678/data/tmp/com.apple.lsdidentifiers.plist : (null)
/Library/Developer/CoreSimulator/Devices/14ABD200-69D3-441D-8FAA-731F5F00F678/data/tmp/ is an empty folder.
Meanwhile, my xcode can not load xib or storyboard properly. "Internal error occurred, Editing functionality maybe limited"
I did clear /Users/myusername/Library/Developer/CoreSimulator/Devices/ folder, doesnt help, re-install xcode doesnt work.
environment: OS: EI 10.11.6, xcode: 8.0 simulator:Version 10.0 (SimulatorApp-700.5.3
The error message is benign and can be ignored. Sorry about the noise in syslog. The issue has since been resolved in the Xcode 8.1 betas.
If you deleted ~/Library/Developer/CoreSimulator/Devices while CoreSimulatorService was running, the service will be in an inconsistent state. You should SIGKILL it to cause it to relaunch in a new state.
Your 'Internal error occurred, Editing functionality maybe limited' error message is likely unrelated to either of those things. Most users see that because they're trying to use multiple copies of Xcode.app at the same time. It's perfectly fine to have multiple Xcodes installed, but you can only use one at a time. If that's not the issue you're seeing, you will need to provide more information about the error.
fixed it by turn off System Integrity Protection in El Capitan.
I totally have no idea when I updated mac os, and got this issue.
Until I noticed that I cant start mysql, which has similar issue 'Could not create unix socket lock file /tmp/mysql.sock.lock'
Then I thought something went wrong with my os settings.
steps:
Restart your Mac.
Before OS X starts up, hold down Command-R and keep it held down until you see an Apple icon and a progress bar. Release. This boots you into Recovery.
From the Utilities menu, select Terminal.
At the prompt type exactly the following and then press Return: csrutil disable
Terminal should display a message that SIP was disabled.
From the menu, select Restart
for more information https://apple.stackexchange.com/questions/193368/what-is-the-rootless-feature-in-el-capitan-really