I have 2 provider on my mikrotik
eth1 - grey dynamic ip
eth3 - pppoe - white statiŃ ip (adsl modem)
How can I connect from winbox to static IP?
/ip firewall mangle
add action=mark-connection chain=input comment="Connmark in from ISP1" connection-mark=no-mark in-interface=ether1 new-connection-mark=conn_isp1 \
passthrough=no
add action=mark-connection chain=input comment="Connmark in from ISP3" connection-mark=no-mark in-interface=pppoe new-connection-mark=conn_isp3 \
passthrough=no
add action=mark-routing chain=output connection-mark=conn_isp1 new-routing-mark=isp1 passthrough=no
add action=mark-routing chain=output connection-mark=conn_isp3 new-routing-mark=isp3 passthrough=no
8291 is open
I can ping to pppoe.
When I try to connect I get " login failure for user xxx from xxx via winbox"
Check ip services print, if www is not enabled just /ip service enable www
Then you can play in Firewall to accept what connection from where/which interface.
Related
On my windows 10 pro laptop I am running geth in WSL. The problem is I can not seem to get reach my wireless router. I am getting a status of not connected to my router. So the web3J calls returns a can not connect. I setup my geth:
geth --http.port "8545" --http.addr "192.168.1.15" --datadir test-chain-dir --http --dev
I setup eth0 to match my address in my ipv4 settings config in my vethernet adaptor
ifconfig eth0 192.168.1.15 and the mask ifconfig eth0 netmask 255.255.255.0
I also add a route ip route add default via 192.168.1.15
So what am I doing wrong? I also tried adding on the windows side the command to setup portproxy.
Is there some definitive instructions somewhere about setting up geth to work within WSL and able to reach out to the router? I wrote some simple code using web3j running on a android phone that is connected on my local network.
Thanks!
I have an openvpn server residing in amazon cloud on subnet 172.168.1.0/24. I have another X-ec2 instance on another subnet 172.168.2.0/24. I am able to not route internet traffic through the VPN by removing
push "redirect-gateway def1"
on the server configuration file. My requirement is that all traffic to instances on amazon cloud on both subnets 172.168.1.0/24 & 172.168.2.0/24 to go through the vpn tunnel so I added in the server.conf
push "route 172.168.1.0 255.255.255.0 vpn_gateway 1"
push "route 172.168.2.0 255.255.255.0 vpn_gateway 2"
I am still unable to reach the X-ec2 instance from my client windows workstation connected to the vpn. Am I missing anything here?
I also came across this Samba Share Over OpenVPN, Split Tunneling? but I done the exact same as told.
Managed to get this to work. I forget two configurations regarding routing.
Routing the clients traffic (https://www.sys-dev.cat/blog/3/)
iptables -t nat -A POSTROUTING -s 10.10.1.0/24 -o eth0 -j MASQUERADE
Enable IP Forwarding in the /etc/sysctl.conf for persistence
net.ipv4.ip_forward = 1
And in my server.conf I changed
push "route 172.168.1.0 255.255.255.0 vpn_gateway 1"
push "route 172.168.2.0 255.255.255.0 vpn_gateway 2"
to
push "route 172.168.1.0 255.255.255.0"
push "route 172.168.2.0 255.255.255.0"
Restart Server when changes done.
I have installed Squid in one digital ocean ubuntu machine.
What I want to do is: I will send a ipv4 address to this proxy server and I need to pick up and use a iPv6 address configured in the squid.conf.
I have added 2 ipv6 addresses in the conf file.
If I try the following command by specifying address as ipv6, it works fine.
curl -H 'Cache-Control: no-cache' --proxy localhost:3128 [2400:xxx:x:xx::xxx:a001]
ie, it will pick a random ipv6 address from the conf file and send the request through that ip address.
If i try the following command by specifying address as ipv4, its not working
curl -H 'Cache-Control: no-cache' --proxy localhost:3128 34.xxx.xxx.148
ie, Its not picking the ipv6 address specified in the conf file. Instead its using the server public ip .
My /etc/squid/squid.conf file content is something like this now.
acl one_fourth_3 random 1/2
acl one_fourth_4 random 1/1
tcp_outgoing_address 2604:xxxx:xxx:xxx::xx:a001 one_fourth_3
tcp_outgoing_address 2604:xxxx:xxx:xxx::xx:a002 one_fourth_4
http_access deny !safe_ports
http_access deny CONNECT !SSL_ports
http_access allow localhost manager
http_access deny manager
http_access allow localhost
http_access allow all
http_access deny all
http_port 3128
My squid version is
Squid Cache: Version 3.5.12
Service Name: squid
Squid implicitly use the IP version, you should use or force IPv6.
Squid will add an implicit IP version test to each line.
Requests going to IPv4 websites will use the outgoing 10.1.0.* addresses.
Requests going to IPv6 websites will use the outgoing 2001:db8:* addresses.
http://www.squid-cache.org/Doc/config/tcp_outgoing_address/
I have a Ubuntu host and an Ubuntu guest. I want to achieve that my host traffic is tunnelled through my guest. Thus enabling me to do analysis on the host traffic from the guest. I am assigning two interfaces to the guest (in addition to the built in NAT interface which is provided by Vagrant). I am creating a bridge interface on the host called br0. One of the guest interfaces is connected via bridging to eth0 (the host interface which is connected to the Internet) and the other guest interface is connected via bridging to the host br0 interface. On the host I am deleting my default gateway and adding a new one with:
route del default
route add default dev br0
After that I can vagrant ssh into my guest and set up a bridge interface there as well with.
brctl addbr br0
brctl addif br0 eth1
brctl addif br0 eth2
After this setup the host traffic should be routed through the guest. If I run
tcpdump -vni br0
inside the guest I can see packets but I can't connect to the Internet. There is something missing. Any ideas?
I had to enable IPv4 forwarding in the guest.
Edit /etc/sysctl.conf to enable forwarding permanently:
net.ipv4.ip_forward = 1
Run this to activate the setting without a reboot:
sysctl -p /etc/sysctl.conf
I'm having problems with proxy/relay applications such as a BNC. I have a CentOS 5.6 VPS with 2 IP addresses which are virtual adapters (venet0:0 and venet0:1) under venet0.
In these applications I can choose which IP address to bind to (IP address of venet0:1) but when they create an outbound connection, it is done through venet0:0.
These are my current settings (found using webmin):
Interfaces
Name Type IP Address Netmask Status
lo Loopback 127.0.0.1 255.0.0.0 Up
Loopback ::1 128 Up
venet0 Unknown 127.0.0.1 255.255.255.255 Up
venet0:0 Unknown (Virtual) xxx.xxx.xxx.xxx 255.255.255.255 Up
venet0:1 Unknown (Virtual) xxx.xxx.xxx.yyy 255.255.255.255 Up
Route and Gateways
Destination Gateway Netmask Interface
169.254.0.0 None 255.255.0.0 venet0
Default Route None venet0
::1 :: 128 lo
Please can someone help me figure out how to configure the VPS?
Try to remove the default routes you do not want. The command ip route list should give you three entries. For example, on my Debian VPS, I get :
192.0.2.1 dev venet0 scope link
default via 192.0.2.1 dev venet0 src 10.15.4.62
default via 192.0.2.1 dev venet0 src 10.15.4.61
I want the VPS to use 10.15.4.61 for outgoing connections, not 10.15.4.62, so I type :
ip route del default via 192.0.2.1 dev venet0 src 10.15.4.62
Now I have a single default route, and my VPS will use the IP I want.